Amazon Connect operational notification
Incident Report for CT Suite Status Page
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 18:25 CST
Update
We are continuing to investigate this issue.
Posted Feb 25, 2021 - 14:09 CST
Investigating
Affected resources: CT Suite Web Client

Description:
This notification applies only if you are using the Firefox web browser with “Enhanced Tracking Protection” browser setting set to “Strict”.

A recent upgrade to Firefox, specifically version 86 released on February 23, 2021, introduced Total Cookie Protection [1] which modified cookie sharing behavior across sites for users with “Enhanced Tracking Protection” set to “Strict” (Firefox defaults to “Standard”). Users with this specific browser setting and version combination may be unable to access the Amazon Connect CCP when embedded in another application, preventing them from handling contacts.
To prevent impact to your users (agents), we recommend that your users do EITHER of the following:
(a) Confirm (or set) “Enhanced Tracking Protection” as “Standard” in their browser settings. Users can do this by following instructions documented here [2].
(b) Do not upgrade their Firefox browser version to v86 or higher.
(c) Use Google Chrome to access the Amazon Connect CCP.
If you have any questions or concerns, the AWS Support Team is available on the community forums and via AWS Premium Support [3].
[1] https://blog.mozilla.org/security/2021/02/23/total-cookie-protection/
[2] https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop#w_adjust-your-global-enhanced-tracking-protection-settings
[3] https://aws.amazon.com/support
Posted Feb 25, 2021 - 14:07 CST
This incident affected: Agent (Client Interface).